Error reading XForm file after offline install

Hello,

We had data that was collected on an old form and we needed to update the
form in the field by doing an offline install. However, immediately after
the offline install, I get an error that says 'Error reading XForm file’
when I try to view the saved data or open a new form. I then saved the data
to an SD card and loaded onto my compuiter, but I cannot make sense of the
XML files as it is in characters. The data was sent to the server, but the
information contained in repeating groups is missing.

Can anyone advise so that I do not use a lot of data?

Thanks,
Jennifer

Hi Jennifer,

Sounds like there are a few things going on here, some of which are
expected behaviors and some of which sound like bugs. Inline:

Hello,

We had data that was collected on an old form and we needed to update the
form in the field by doing an offline install. However, immediately after
the offline install, I get an error that says 'Error reading XForm file’
when I try to view the saved data or open a new form.

If you’re opening Saved or Incomplete forms and seeing an error message,
its possible you’ve encountered the issue described here
https://confluence.dimagi.com/display/commcarepublic/CommCare+for+Android+Force+Close+from+Loading+Incomplete+Forms
where
the most recent form and saved data have gotten out of sync. Unfortunately
this is expected behavior and as such we don’t encourage saved forms to be
used as part of a standard workflow.

or open a new form.

However, if you’re encountering this error upon trying to start a new form
this sounds like a real bug - could you share a screenshot of the error
message?

I then saved the data to an SD card and loaded onto my computer, but I
cannot make sense of the XML files as it is in characters.

Can you specify how you did this? If you just copied the forms directly
from the CommCare application folder on your device then these files are
encrypted which is why they’d appear as jumbled bytes when opened. They
need to be submitted to HQ by the authorized user in order to be decrypted.

The data was sent to the server, but the information contained in
repeating groups is missing.

Can you clarify what you mean by this? If data is missing from your forms
then you should definitely report a bug
https://confluence.dimagi.com/display/commcarepublic/Bug+Reports following
the instructions provided.

··· On Mon, May 22, 2017 at 8:54 PM, Jennifer Head wrote:

Can anyone advise so that I do not use a lot of data?

Thanks,
Jennifer


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.