Connection timed out between formplayer and HQ

After configuring the ports for the communication between FormPlayer and HQ, the connection seems to disconnect because FormPlayer does not respond.

My configs are:

localsettings.py
FORMPLAYER_URL = “https://monolith.panoimagen.local:8181

application.properties:
commcarehq.host=https://monolith.panoimagen.local
commcarehq.environment=monolith
commcarehq.formplayerAuthKey=panoimagen
server.port=8181
user.suffix=panoimagen.com

Can anyone tell me if these configs are alright? I did the installation with monolith environment, so everything is inside a VM.

It appears as if you have manually edited the localsettings.py file to change FORMPLAYER_URL. We recommend using commcare-cloud and don’t recommend manually editing localsettings.py on your server, since running commcare-cloud <env> update-config will then overwrite your changes.

It defaults to /formplayer, with the nginx proxy having an entry routing /formplayer to your local formplayer service on the correct port. The setup as shown here may work, but that would require formplayer being accessible at https://monolith.panoimagen.local:8181—though I think this setup is not well tested, so I can’t say that with much certainty.

Feel free to correct any misunderstandings I might have had about your setup, but just from what I’m seeing I would recommend sticking with the settings that you can configure through commcare-cloud config files.

I also want to point out that commcarehq.formplayerAuthKey is supposed to be a private key not to be shared publicly. It sounds like this is just in a local VM that will not be exposed to the public internet, but if you’re planning on using the same setup for a production server, I’d strongly recommend setting FORMPLAYER_INTERNAL_AUTH_KEY in vault.yml to something long and random.

Thanks for the reply.
If this config is not well tested, then which config should I try? I have the installation on a single VM, and I am looking forward to use in production after I can make it work on testing.

I mean that I dont know which config setting is used in the env files to change the formplayer URL.

And yes, you are correct, the formplayer should be on that address

Hi Pablo,

There is currently no supported way to change the FORMPLAYER_URL setting using commcare-cloud. It is meant to always keep its usual value of /formplayer.

Perhaps you can talk about why you wanted to change that setting. Was the out of the box setup not routing /formplayer to the correct place?

Best,
Danny