CommcareHQ + Ubuntu

[This is copied to the group so we can have everyone involved as well
as serve as reference for future users]

··· ---------- Forwarded message ---------- From: Nahid Hossain

We have installer all the packages required for CommCareHQ+RapidSMS in
Ubuntu. Somehow we couldn’t get the landing page when we are browsing
our installation URL. Could you please have a look in to it?

Hi Nahid,

The error I’m seeing is “ImportError at / cannot import name
redirect”, for this line of code:

from django.shortcuts import redirect

Django.shortcuts.redirect is part of Django since version 1.1 (
http://docs.djangoproject.com/en/dev/topics/http/shortcuts/#redirect )

  • could you verify the Django version you’re running is >= 1.1?

In order to do so, run “python manage.py --version” in the Commcare
root directory. If the version is <1.1, you can find a newer install
here: http://www.djangoproject.com/download/ (currently we support
Django 1.1, some features may not work in 1.2)

Thanks,
Nir

Thanks Nir.
It works great now. In our ubuntu system, 1.0.2 of Django was installed
using .deb package. We removed the old version and installed 1.1.2 version
from tar ball.

Thanks again for your advice.

Regards
Nahid

··· -----Original Message----- From: commcare-developers@googlegroups.com [mailto:commcare-developers@googlegroups.com] On Behalf Of Nir Yariv Sent: Sunday, June 27, 2010 5:27 AM To: commcare-developers@googlegroups.com Cc: Nahid Hossain Subject: Re: CommcareHQ + Ubuntu

Hi Nahid,

The error I’m seeing is “ImportError at / cannot import name
redirect”, for this line of code:

from django.shortcuts import redirect

Django.shortcuts.redirect is part of Django since version 1.1 (
http://docs.djangoproject.com/en/dev/topics/http/shortcuts/#redirect )

  • could you verify the Django version you’re running is >= 1.1?

In order to do so, run “python manage.py --version” in the Commcare
root directory. If the version is <1.1, you can find a newer install
here: http://www.djangoproject.com/download/ (currently we support
Django 1.1, some features may not work in 1.2)

Thanks,
Nir