Commcare-Export tool error for CentOs and Maria

Hello There,

We are currently using the commcare-export tool to export data to our local
DB (MySQL) on our Local Machine (Ubuntu-14.04). This works like a charm.

However when we try to work the same commcare-export tool on CentOs (7.2)
server which has MariaDB, it causes an error.

We are using the following command to call the commcare-export tool:

commcare-export --output-format sql --output
mysql://:@localhgst/?charset=utf8 --project
--query .xlsx --username --password
--missing-value='---'

We are getting the following error:
Argument Error : could not pass rfc1738 url from string (Connection String).

Please find attached image for refernce.

https://lh3.googleusercontent.com/-VZfx870HEPM/WEfBLX1KeII/AAAAAAAAGdA/gsImfvDMTBwPDRhaf8b3Nsn_7H7NwfvUwCLcB/s1600/Error_File.png

We suspect that the issue is due to the MariaDB with mysql connection
string.

Any help is appreciated.
:slight_smile:

The connection string in the error message is incorrect (it has ":"
instead of "://"). Please check that your connection URL is correct.

ยทยทยท On 7 December 2016 at 09:58, mufaddal nullwala wrote:

Hello There,

We are currently using the commcare-export tool to export data to our
local DB (MySQL) on our Local Machine (Ubuntu-14.04). This works like a
charm.

However when we try to work the same commcare-export tool on CentOs (7.2)
server which has MariaDB, it causes an error.

We are using the following command to call the commcare-export tool:

commcare-export --output-format sql --output mysql://:@
localhgst/?charset=utf8 --project --query
.xlsx --username --password
--missing-value='---'

We are getting the following error:
Argument Error : could not pass rfc1738 url from string (Connection
String).

Please find attached image for refernce.

https://lh3.googleusercontent.com/-VZfx870HEPM/WEfBLX1KeII/AAAAAAAAGdA/gsImfvDMTBwPDRhaf8b3Nsn_7H7NwfvUwCLcB/s1600/Error_File.png

We suspect that the issue is due to the MariaDB with mysql connection
string.

Any help is appreciated.
:slight_smile:

--
You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Simon Kelly
Senior Engineer | Dimagi South Africa